KryoFlux stopped working

All questions about how to use KryoFlux go here.
Post Reply
Posts: 1
Joined: Sat Jan 16, 2021 12:45 pm

KryoFlux stopped working

Post by girv »

I've been using my KryoFlux successfully, on and off, for a number of years. Just recently though it started to not function as shown in this short video clip: (YouTube)

That is running "dtc -c2" on a Windows 10 machine, and I get the same on a Windows 10 VM on macOS. The floppy drive is a Sony MPF920 which has worked perfectly before, and I have also tried a second floppy drive with the same results.

I'd appreciate any suggestions what the problem might be :)
Posts: 644
Joined: Tue Dec 06, 2011 9:09 pm

Re: KryoFlux stopped working

Post by ZrX »

What's the response you get after running the c2 calibration test?

Sounds a bit like something wrong with the stepper motor. Do you have other drives to test with or a way to test the drive in some old computer?
Posts: 368
Joined: Fri Nov 08, 2013 10:48 pm

Re: KryoFlux stopped working

Post by brightcaster »

Could also be the track zero sensor not being recognized! I would check for dust on the sensor first. If that doesn't solve it, I would try a different cable...

I agree with ZrX in that the printing on the screen would be much more helpful than the video in this case!

User avatar
Posts: 2164
Joined: Tue Oct 05, 2010 5:48 pm

Re: KryoFlux stopped working

Post by mr.vince »

Could also be a lose connection or a bad cable. Have had this before.
Post Reply