Page 3 of 6

Re: Installing KryoFlux in Windows 8 / 10

Posted: Sun Jan 24, 2016 8:44 pm
by DrCoolZic
mr.vince wrote:BTW from the post above... it seems to be (maybe) related to some Arduino software installed. Although Windows can update installed drivers, it should not change drives based on USB ID assumptions. And while it prefers the Bossa driver for an initial setup, it's all fine here once installed.

So maybe you have some kind of Arduino development suite that will "fix" the driver assignment?
No I have nothing related to Ardruino

Re: Installing KryoFlux in Windows 8 / 10

Posted: Mon Jan 25, 2016 6:40 pm
by mr.vince
Then I have no clue why you have a Windows installation that is so special in this regard. Does not happen here. Are you maybe using a hub?

Re: Installing KryoFlux in Windows 8 / 10

Posted: Mon Jan 25, 2016 9:08 pm
by DrCoolZic
If you look at what is indicated here viewtopic.php?f=2&t=1038
it does not seems that I am the only one having this problem.

and no I do not use an USB hub

Re: Installing KryoFlux in Windows 8 / 10

Posted: Tue Jan 26, 2016 12:08 pm
by DrCoolZic
For information I have tested the KF board on two Windows 10 systems: one running Windows 10 Home edition, and one running Windows 10 Pro edition. On both system Windows 10 threshold 2 (aka 1511) has been installed from an ISO downloaded from Microsoft

On the Home edition I did not had any problem. First time I plugged the KF board the system asked for a driver and I could load the KF driver that was not updated after restarting the system.

But on the Pro system when I first plugged the KF board the system did not ask for any driver and automatically loaded the Bossa driver?

It seems that the information about the driver comes from the arduino-org.inf file located in the dreaded C:\Windows\System32\DriverStore\FileRepository directory.

In this inf file you find
...
[DeviceList]
%due.bossa.name%=DriverInstall, USB\VID_03EB&PID_6124
%due.programming_port.name%=DriverInstall, USB\VID_2A03&PID_003D
%due.sketch.name%=DriverInstall, USB\VID_2A03&PID_003E&MI_00
%esplora.bootloader.name%=DriverInstall, USB\VID_2A03&PID_003C
...
But as I do not do anything related to arduino I have no idea why this file is there?

Anyway since I have blocked the Bossa driver update with the procedure described in this thread the Kryoflux driver is consistently loaded after many system restart and many system update (automatic or forced).

So hopefully the proposed solution seems to permanently fix the problem.
As Istvan mentioned the Bossa driver should never have been added to the MS driver database :(

Re: Installing KryoFlux in Windows 8 / 10

Posted: Fri Jan 29, 2016 9:21 am
by mr.vince
DrCoolZic wrote:If you look at what is indicated here viewtopic.php?f=2&t=1038
it does not seems that I am the only one having this problem.
I think you are the only one with this very problem; e.g. it works for Barry, I can't say if the other report is related. BUT: Considering we have thousands of units out there and 95% Windows users (with many of these having switched to W10), and given the fact that not everyone uses home (I am using Pro 64bits), I am _very_ confident that (Murphy's law: You have 1000 happy customers, one unhappy, but he makes sure he sounds like ten thousend online - on forums, Facebook and other places) we've gotten more reports here.

I only need to replace the driver once. That's it. I have to replace it again if I use a different USB port. So it might be that e.g. hydr0x has a notebook with an internal hub (many of them have) which enumerates the board every time you connect it, even though you use the same port.

Anyway, this is not something that can be remedied easily. The Atmel ID should be "free" to use, as it's meant for development. Now why didn't we change it: People can and are allowed to build their own personal boards. Since there is no need to flash anything the only reason to flash would have been the ID, nothing else.

So now we have to live with it. In the same way like with the fact that Apple broke some USB stuff in El Capitan, breaking certain devices that do "raw" communication over the bus, e.g. USB dongles - or KryoFlux. We rely on Apple fixing it; we currently have no plans to fix something in an operating system. These fun changes by OS devs (for no apparent reason) can easily take up all our resources and completely stall KF development. We're not going to let this happen.

Realistically: You can always use a VM to sandbox an environment just for KryoFlux.

Re: Installing KryoFlux in Windows 8 / 10

Posted: Sun Jan 31, 2016 3:01 pm
by hydr0x
Yes, I'm using a laptop with an internal hub, so it's indeed possible that that's to blame. However, I don't see these issues every time I reconnect, I only noticed them after taking longer breaks from imaging disks. So it's entirely possible that Windows updates installed during those breaks are the culprit.

Having said that, I wouldn't overestimate the amount of Win 10 KF users. Most of your real clients are institutions which surely haven't switched to Win 10 yet and a lot of your normal users are using their retro platforms and/or dedicated systems for the dumping, not to mention there seems to be a general adversity among more technically literate users against Windows and especially new Windows. So I think W10 is still rare among your users.

Re: Installing KryoFlux in Windows 8 / 10

Posted: Mon Feb 01, 2016 7:14 pm
by mr.vince
I am surprised you seem to know better about our users than we do. :)

Still - even if this would be true we can't enforce Microsoft to do or not do something. We can discontinue support and ask people to run a pre-made Linux in a VM or similar.

Re: Installing KryoFlux in Windows 8 / 10

Posted: Thu Feb 04, 2016 8:18 am
by menace
Actually, publishing a pre-made linux vm with a working setup is pretty great idea - certainly hope you do that!

Re: Installing KryoFlux in Windows 8 / 10

Posted: Fri Feb 05, 2016 9:02 pm
by hydr0x
mr.vince wrote:I am surprised you seem to know better about our users than we do. :)
Of course I don't ;) But as I develop business applications as a daytime job I have a pretty good idea how reluctant some user groups are to update their OS.

Re: Installing KryoFlux in Windows 8 / 10

Posted: Sat Feb 27, 2016 9:47 am
by breiztiger
hi

with last insider build Windows 10 (14271) kryoflux doesn't work anymore

;-(

EDIT : To work again, you have to uninstall driver and reinstall again on bosa driver