Control command rejected by the device

All questions about how to use KryoFlux go here.
dlfrsilver
Posts: 119
Joined: Fri Nov 12, 2010 8:08 pm

Re: Control command rejected by the device

Post by dlfrsilver »

I got the very same problem when dumping amstrad CPC Overlander from elite. The retail disk release is copyprotected, and the kryoflux tool choke on it everytime it tries to read it. Other amstrad CPC disk dumped correctly. So this can't be related to the hardware. (ST and amiga disk dumping work correctly.

I have uploaded dumps on the SPS server ?

User avatar
Interceptor
Posts: 58
Joined: Wed Oct 06, 2010 10:17 am

Control command rejected by the device

Post by Interceptor »

You say overlander doesn't work but then say you've uploaded it?

Don't see how a disk can cause that error.

User avatar
mr.vince
Posts: 2135
Joined: Tue Oct 05, 2010 5:48 pm

Re: Control command rejected by the device

Post by mr.vince »

Have you?! :)

I'd like to see the logs... just in case. Can you paste them here?

Can you please, in the same session, try dumping a disk that was fine before? Thanks.

Acshi
Posts: 2
Joined: Thu Feb 16, 2012 8:19 pm

Re: Control command rejected by the device

Post by Acshi »

I have just got a KryoFlux and trying to use it for the first time I am getting this error, but I think my circumstances are different from what as already been discussed here. I have no troubles getting it to read from the second floppy drive, which is 3.5", but with the first, a Mitsumi D509V3 5.25", I get

Code: Select all

DTC -d0 -c2
Control command rejected by the device
CM: maxtrack=0
And similar things from most other commands, except for

Code: Select all

DTC -d0 -c3 -i6
CM: rpm=360.594, avg=360.594
CM: rpm=360.639, avg=360.616
I have tried using the slower firmware and plugging in the extra power to the KryoFlux, but that hasn't helped. The floppy cable is keyed and because the 3.5" works fine I do not think there is a wiring issue there, but I am not sure at all about all the possible KryoFlux settings that may affect something like this. -- I do have the headers for two drives put as they are shown for two drives in the quickstart guide, though.

All help appreciated,
Acshi

User avatar
mr.vince
Posts: 2135
Joined: Tue Oct 05, 2010 5:48 pm

Re: Control command rejected by the device

Post by mr.vince »

Hi, can you please try setting the device to one drive only and only attach the 5.25" drive? It's unlikely that this is the issue, but let's start with the basics.

Acshi
Posts: 2
Joined: Thu Feb 16, 2012 8:19 pm

Re: Control command rejected by the device

Post by Acshi »

Wonderful! I just did that and now the 5.25" reads just dandy. I reset everything to use both drives, but made the 5.25" drive1 instead of drive0 as it had been before, and now they both read (with either fast or slow firmware). I'm not sure if that really was my problem, but thank you for the quick support.

Post Reply