Page 3 of 4

Re: Missing Index Error

Posted: Mon Oct 17, 2011 12:28 am
by girv73
I've just received a KryoFlux (Rev D) and hooked it up to an Amstrad 3" FDI-1 drive. The drive calibrates (-c2) all right, but I'm getting the "missing index" error reported on this thread when I attempt to dump a disk.

Code: Select all

C:\kryoflux_2.0b3_windows\dtc>dtc -i4 -ftest.mfm -l15
00009ab4: status=0
00009ac8: status=0
00009adc: reset=0
00009f21: info=1, name=KryoFlux DiskSystem, version=2.00s, date=Aug 19 2011, time=01:13:14
00009f35: info=2, hwid=1, hwrv=1, sck=24027428.5714285, ick=3003428.5714285625, wb=32768, wa=64, wq=8, wt=65535
00009f49: device=0
00009f5d: density=0
00009f71: min_track=0
00009f85: max_track=83
KryoFlux DiskTool Console, v2.00 beta 3, uiv.1, Sep 16 2011, 18:07:26
(c) 2009-2011 KryoFlux Products & Services Ltd.
Developed by The Software Preservation Society, www.softpres.org
Licensed for private, non-commercial use only.

00009f99: motor=1
0000a31a: side=0
0000a32e: track=0
0000a342: stream=1
0000a77d: stream=0
00.0    : The streaming device reported missing index - no disk in drive
00.0    : Read operation failed

Enjoy your shiny new disk image!
Please consider helping us to preserve media and continue development:
www.softpres.org/donate

0000a791: motor=0
I tried:
- different connector on the floppy cable (new cable, came with the KryoFlux)
- fast/slow firmware

Anything else I should try or check?

Re: Missing Index Error

Posted: Mon Oct 17, 2011 9:44 am
by mr.vince
Ok, even new cables can be broken. That does not mean it happens often. But can... just for the record. As well as the board. These boards are tested but... you never know what happens during transit.

I'd be tempted to say please try a different drive. I know that many 3" drives do their last breath when people connect them to power. The reason is that these drives have their power adapter "crossed". If you power them with a molex, you must _usually_ do so by plugging it in flipped (180 degrees). Otherwise you fry the drive.

Drives that don't spin or do anything, but do respond to stepping, usually show this error.

Do you have a 3.5" drive to test?

Missing Index Error

Posted: Mon Oct 17, 2011 4:37 pm
by Interceptor
I expect the drive belt is broken, these cost about £1 and it takes about 20 mins to replace.

I've had to replace the belt on every 3" drive I've had.

Re: Missing Index Error

Posted: Tue Oct 18, 2011 10:43 pm
by girv73
I was able to image an AmigaDOS disk in a 3.5" floppy (dtc -i5) using the same cable, so it looks like the FDI-1 isn't working. I've ordered a replacement belt off eBay...

Missing Index Error

Posted: Wed Oct 19, 2011 7:06 am
by mr.vince
Nice. Please keep us posted!

Re: Missing Index Error

Posted: Thu Oct 20, 2011 12:58 am
by girv73
Belt replaced - the old one had degraded so badly it had melted to the drive wheels and had to be scraped off with the end of a screwdriver!

I've now managed to create dtc -i4 MFM images of a few 3" AMSDOS disks, which is nice, but fairly useless unless I can use them in emulators. Is there any specification available for the -i4 file format? Can it be converted to DSK for standard format disks?

The good part is that I have a few CPC original disk games that haven't been dumped yet :)

Missing Index Error

Posted: Thu Oct 20, 2011 10:37 am
by Interceptor
Another drive resurrected :)

You will also find that since the drive rpm is not digitally controlled that it changed depending on how stiff the inserted disk is. Thats not a problem in the kryoflux era though.

as for DSK, perhaps it can be added if mr IFW gets a moment, but EDSK is not currently on the cards.

Slightly on-topic, Simon Owen's samdisk utility can convert ipf to edsk where the format allows it.

And there is a version of caprice32 that supports ipf. As does spectaculator for speccy disks.

Re: Missing Index Error

Posted: Thu Oct 20, 2011 12:30 pm
by girv73
I'm fairly sure I could write a MFM->DSK converter for standard formats. I've done MFM decoders before, and DSK converters, just never both in the same program :) Just need the MFM sector and data interleave layout information...

IPF support is nice. Pity I can't find any CPC IPFs ;)

Re: Missing Index Error

Posted: Thu Oct 20, 2011 7:44 pm
by CholoCPC
Another Amstrad user here too (i also use 3" DF1-drive with Kryoflux) :D

I was thinking the same thing: it would be nice if there was a easy way to convert MFM to normal DSK for Amstrad/Spectrum+ users. Not only for emulator use but also as a safe way to backup your old data discs (as you can write/read the DSK back to amstrad floppy if you have a HxC floppyemulator or similar too).
I somehow dont think SPS would be interested in or would want to translate my bazillion error filled 3" data floppies to IPF as we arnt talking about original games discs. So having a way to turn your own data disc dumps to dsk would be really nice.

Ive looked into it before actually but as im not that technically it has mostly been trying weird combinations of software. Like .. tried renaming a MFM dump to IMG and load it up HxC disc converter software and then export it to DSK .. and amazingly the dsk wasnt rejected by either CPCE or WinApe emulators .. alas i only got a partial file catalogue (and the DSK file was way to large too) so something obviously went wrong somewhere in the "translation".

I did cross my mind that samdisk might be usefull. I know a lot of people use it for dumping amstrad floppies:
http://simonowen.com/samdisk/

And feedback if anyone finds a way would be appreciated ;)

Not working v2: Anyways what version of the Kryoflux software are you using with your DF1? Ive used version 1.0b10r4 for windows so far without any problems .. but when i tried the new v 2.0 b3 yesterday i just cant get it to calibrate? (board rev 2, Vista 64). I keep getting "Control command rejected by device" or it calibrates "succesfully" with tracks = 0. Ive tried the slow firmware (and resetting and the fast again and the slow one again and a lot more resetting and rebooting) but still the same. Nothing wrong with the hardware setup as the second i go back to v1 again it all works wonderfully again.

Re: Missing Index Error

Posted: Thu Oct 20, 2011 11:16 pm
by girv73
I'm using the latest software "v2.0 Beta 3, 2011-09-23" on Windows 7 Ultimate x64 and a KryoFlux Rev D.