Page 1 of 4

Missing Index Error

Posted: Sat Nov 06, 2010 10:25 pm
by Pix

I've tried my Kryoflux with several different drives including a Teac FD-55GFR which has been confirmed working on these boards. When I attempt to read the maximum track using dtc -c2 it returns maxtrack correctly. However when I've attempted to read a disk on any of the drives I always receive the following error:-

00.0 : The streaming device reported missing index - no disk in drive
00.0 : Read operation failed

What am I doing wrong?

Re: Missing Index Error

Posted: Sat Nov 06, 2010 10:59 pm
by esynthesist
I had the same problem with the same Teac drive and the Kryoflux.
I didn't panic though because I immediately suspected that this drive was "in a deep sleep" due to not having been used in my computer for more than 2 years.
In fact I encountered this kind of problem also on my vintage computer equipment (8088, 80386DX, ...)
The solution was always to "wake it up" and "bring it under the living again" by doing many (really many !) attempts to access the drive.

So I installed my Teac back in my 80386, entered a floppy disk and did a "B:" command in DOS. Result: error, drive/disk could not be found by DOS.
I repeated this "B:" command about 50 times and finally the PC kind of started detecting the drive/disk.
After about 30 "DIR *.*" commands it could also read the disks again, and from then on reading/writing worked fine on the 30386.

I reconnected the drive to the Kryoflux and now it's working like a charm !

(jumper settings: only DS1 and DC are jumpered on mine)

Re: Missing Index Error

Posted: Sun Nov 07, 2010 12:00 am
by Pix
That doesn't seem to be the problem here. To make sure, I just tried connecting the Teac drive the old fashioned way and imaged a disk using Winimage. It worked straight off without any problems but the drive still wasn't working when I tried it with Kryoflux afterwards. My jumper settings are the same as yours. The Teac drive had been sat around for ages but I'm getting the same thing with a 3.5" Mitsumi D359M3D which I was just using the other week as well as a couple of other drives.

Re: Missing Index Error

Posted: Sun Nov 07, 2010 9:11 am
by mr.vince
Does it work with any drive you have? I've tested every unit before shipment, so I don't assume the unit is dead...

Can you please retry with some drives and turn on full logging with -l15?

I recently got a 5.25" drive that also does not seem to report an index. Maybe it's a filtering glitch... we'll look into this.

Re: Missing Index Error

Posted: Sun Nov 07, 2010 4:40 pm
by Pix
I've tried it with every drive I've got to hand which are the two I've mentioned + a Canon MD5511-V6 3.5/5.25 dual drive and a 2.4 MB 5.25 floppy drive which I don't know the model id of. Other than reporting different maxtracks, they all behave exactly the same when I try to use them with the Kryoflux board and I've not managed to image any disks with it yet. The output with l15 when trying to image a 1.2 MB PC disk is:-

Code: Select all

C:\dtc>dtc -fimage.img -i4 -l15
00064485: status=0
00064499: status=0
000644ad: reset=0
000647e9: descriptor=C2 DiskSystem/version=1.00/date=Oct 12 2010/time=20:06:17
000647fd: device=0
00064811: density=0
00064825: min_track=0
00064839: max_track=83
KryoFlux DiskTool Console, v1.00 beta 7, uiv.1, Oct 12 2010
(c) 2009-2010 Istvan Fabian, Softpres,
Licensed for private, non-commercial use only.

0006484d: motor=1
00064b5e: side=0
00064b72: track=0
00064b86: stream=1
00064fb8: stream=0
00.0    : The streaming device reported missing index - no disk in drive
00.0    : Read operation failed

Enjoy your shiny new disk image!
Please consider helping us to preserve media and continue development:

00064fe0: motor=0
I thought it might possibly be an issue with the drives power supply so I used that when I connected the Teac to my PC to confirm it was working ok. I've confirmed that all the floppy drives work when I use them through a standard floppy connection and I've also tried using the board with my laptop instead of my desktop PC. I'm out of ideas at this point. I would have expected at least one of these drives to work.

Re: Missing Index Error

Posted: Sun Nov 07, 2010 6:03 pm
by mr.vince
Hm. Ok, I wrote I had a drive here that had the same issue... missing index. As it turned out, this special NEC drive 1155D is from a PC-98. It has a special clamping mechanism that locks the disk and attaches it to the motor spindle. I still have not found how to trigger it, but manually pressing down the clamp does the trick. So unfortunately no further information I could draw from this one.

So let's check everything step by step. All I can tell atm is that dual drives are usually a source of joy (beware, sarcasm).

When you connected the drives to your PC, did you use the same cable? Maybe the cable is broken.

How is the jumper config on the KryoFlux board? Two drives? One? What happens when you set them to opposite? If the drive is on the part of the cable before the twist (as seen from the host-connector), it is unit 1, so you would have to use option -d1 to tell DTC to use drive 1 instead of 0 (which is per default, otherwise you could specify this: -d0).

Re: Missing Index Error

Posted: Sun Nov 07, 2010 6:37 pm
by Pix
I wasn't too optimistic about the dual drive but I thought I'd give it a go when the other 3 didn't get me anywhere.

I'm using the same floppy cable so it's not broken. I'd already tried using the -d0/1 switch with both connectors with no joy. The jumpers were set to the single drive position. I've just tried with them in the 2 drives position with the Teac and Mitsumi connected up together. It accesses each drive correctly with the -d switch but I'm still getting the same no disk error with both of them.

Re: Missing Index Error

Posted: Sun Nov 07, 2010 7:08 pm
by mr.vince
Ok, not sure if the original FDC will need the index or work by using the sync word ($4489) only. If it's the latter, you could read the disk with your PC, but can't with KryoFlux as it depends on the index for timing...

Can you swap the cable for another one?

Re: Missing Index Error

Posted: Sun Nov 07, 2010 7:24 pm
by Pix
It's a brand new cable but I've tried swapping it for a different one and that didn't work either.

Re: Missing Index Error

Posted: Sun Nov 07, 2010 8:28 pm
by mr.vince
Alright, will think about options. Have also emailed you in case we exchange the board.

Sorry for the inconvenience.