Error: Side number found is different from what it should be

All questions about how to use KryoFlux go here.
Post Reply
Matt
Posts: 2
Joined: Sat Jan 30, 2021 12:00 pm

Error: Side number found is different from what it should be

Post by Matt »

I have the 'side number found is different' for all sectors on side 1 when reading 5.25" DS/DD diskettes, assumed to be 360K. They are from a DOS PC. (1.2MB DS/HD diskettes are working fine, it's just the DD diskettes which have this problem. I have also had no problems with 3.5" diskettes.)

DD images cannot be opened with WinImage (which gives no information about why it failed, just "Error: File xxxx is not image file"). Again, WinImage works fine with 1.2MB images.

I have tried playing with all the settings (RPM 300/360, 40/80 tracks/ sector count 8/9, side mode, etc). I have also tried two different 5.25" disk drives - both exhibit exactly the same behavior.

Anyone have any ideas?

Image
Attachments
Errors.png
brightcaster
Posts: 379
Joined: Fri Nov 08, 2013 10:48 pm

Re: Error: Side number found is different from what it should be

Post by brightcaster »

Can you check if the problem also exists if you dump 720k 3,5" floppies? Looks as if the HD and SIDE1 signals interfere each other...

Could be a broken resistor array R-MAT1 on the kryoflux board (schematics are in the schematics folder of your kryoflux installation).

David
Matt
Posts: 2
Joined: Sat Jan 30, 2021 12:00 pm

Re: Error: Side number found is different from what it should be

Post by Matt »

Hi David,
Thanks for your response. I tried it with 3.5", all densities, and it works. I also changed the cable, it was the same. I now think the diskettes are CP/M 2.2 formatted, not DOS after all.
I'm now playing with cpmtools (http://www.cpm8680.com/cpmtools/cpmcp.htm), and can at least get a directory listing now, but I'm having trouble with the [unknown] disk definition which I have to define in the 'diskdef' file (and that's not working either, but that's my problem now :-) ...

diskdef tatung
seclen 512
tracks 40
sectrk 9
blocksize 1024
maxdir 64
skew 0
boottrk 2
os 2.2
end

Bye, Matt
brightcaster
Posts: 379
Joined: Fri Nov 08, 2013 10:48 pm

Re: Error: Side number found is different from what it should be

Post by brightcaster »

No matter if it's DOS or CPM it should switch from side0 to side1 and give you no yellow "S"! It looks as if you read side 0 twice instead of both sides! You can check that if you dump the sides separately ("File/Settings/MFM Sector Image/Side Mode" from GUI menu). Both images should be identical if my assumption is right...

BTW: If it's a Tatung Einstein it's maybe neither DOS nor CPM but MOS or xtal. There is a great source of information here:

http://www.connectingcomputers.xyz/tatu ... ulator.pdf

http://www.connectingcomputers.xyz/tatu ... /edip.html

http://www.tatungeinstein.co.uk/front/e ... onthly.htm

The EDIP Program will get the files off the image

http://www.connectingcomputers.xyz/tatu ... d/EDIP.ZIP

David
SomeGuy
Posts: 311
Joined: Wed Feb 18, 2015 8:18 pm

Re: Error: Side number found is different from what it should be

Post by SomeGuy »

That attched screen shot show a disk with 80 tracks, not 40 tracks. So what disk was that?

Double check with a known good double sided 5.25" disk of the same density and see if you get the same results.

Could you post a Preservation Stream disk dump? That might help give some extra clues what is going on.
brightcaster
Posts: 379
Joined: Fri Nov 08, 2013 10:48 pm

Re: Error: Side number found is different from what it should be

Post by brightcaster »

Yes, the diskdefs with 40 tracks would mean singlesided 48tpi. Doublesided floppies with 48 tpi are 80 tracks and doublesided floppies with 96 tpi are 160 tracks in cpmtools diskdefs (Tracks = Cylinders * Sides)!

For me it looks as if a 80 tracks drive was connected to the tatung einstein. But the einstein can only handle 40 tracks, hence the second half of the first side is untouched (green).

So yes, a stream dump would help much...

David
Post Reply