Strange problem with 3.5" drive "clicking"

All questions about how to use KryoFlux go here.
Post Reply
SunDown79
Posts: 13
Joined: Tue Jun 09, 2020 4:57 pm

Strange problem with 3.5" drive "clicking"

Post by SunDown79 »

So I have been using my Kryoflux for a while but now all of a sudden I have this strange problem.
This is what happens :

I connect my kryoflux with the USB cable to my PC with the 3.5" drive connected but not powered on.
Then I power on the 3.5" diskdrive and its starts clicking immediately, a bit like an Amiga system does only faster (less than 1 second per tick,click or how you want to call it).

Calibrating works as expected and the clicking stops when it calibrates but continues when it finishes.
Also changed the floppy cable and drive but same behaviour.

Anybody any clue what is happening ?
https://classic.technology - My collection of brochures
brightcaster
Posts: 351
Joined: Fri Nov 08, 2013 10:48 pm

Re: Strange problem with 3.5" drive "clicking"

Post by brightcaster »

Did you try a different power supply? Huge power supplies sometimes show this behavior. They only work, if there is a certain load connected. As long as the drive spins everything looks fine, but in standby mode it always starts again and the drive seeks for track 0 which makes a clicking sound ...

David
SunDown79
Posts: 13
Joined: Tue Jun 09, 2020 4:57 pm

Re: Strange problem with 3.5" drive "clicking"

Post by SunDown79 »

Oww yes I did change to a bigger power supply because I expected my smaller power supply to be broken.
Will check!
https://classic.technology - My collection of brochures
User avatar
mr.vince
Posts: 2158
Joined: Tue Oct 05, 2010 5:48 pm

Re: Strange problem with 3.5" drive "clicking"

Post by mr.vince »

Is the drive directly powered (and not through the KF board)?
SunDown79
Posts: 13
Joined: Tue Jun 09, 2020 4:57 pm

Re: Strange problem with 3.5" drive "clicking"

Post by SunDown79 »

Yes, it is directly powered
https://classic.technology - My collection of brochures
SunDown79
Posts: 13
Joined: Tue Jun 09, 2020 4:57 pm

Re: Strange problem with 3.5" drive "clicking"

Post by SunDown79 »

And ideed, it was the power supply that simply had too little to do.
After I added a MFM harddisk the problem was over.
Will go search for a better matching power supply :)
https://classic.technology - My collection of brochures
Post Reply