Page 2 of 2

Re: Running KryoFlux GUI (Debian 10)

Posted: Sat Feb 08, 2020 10:32 pm
by fryo
It seems there is no connection to the KryoFlux board when running the GUI without 'sudo'. Unfortunately, 'sudo' is not available here on Debian by default:

Code: Select all

sudo java -jar kryoflux-ui.jar
user is not in the sudoers file.  This incident will be reported.
So I tried 'su -', but the GUI still fails to start.

Code: Select all

su -
java -jar kryoflux-ui.jar
Exception in thread "AWT-EventQueue-0" java.awt.HeadlessException: 
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
Can someone please help me with this issue?

Re: Running KryoFlux GUI (Debian 10)

Posted: Sun Feb 09, 2020 1:20 pm
by brightcaster
Looks like if you installed "default-jre-headles" instead of "default-jre" for me!
David

Re: Running KryoFlux GUI (Debian 10)

Posted: Sun Feb 09, 2020 10:12 pm
by fryo
I enabled sudo access (usermod -a -G sudo username) and now KryoFlux works as expected!

Re: Running KryoFlux GUI (Debian 10)

Posted: Mon Feb 10, 2020 10:42 am
by brightcaster
If DTC runs without root rights the GUI should do it also. If not it will be a matter of java and other java apps will show the same behaivior.

Maybe you installed both "default-jre-headles" and "default-jre". Uninstalling "default-jre-headles" and reinstalling "default-jre" should do the trick without sudoing.

David

Re: Running KryoFlux GUI (Debian 10)

Posted: Sat Feb 15, 2020 10:54 am
by fryo
I installed 'adoptopenjdk-8-hotspot' because 'default-jre' does not work. Please check previous posts.