Page 1 of 1

Problems (probably me)

Posted: Sun Feb 03, 2019 6:55 pm
by MarkYoungIW
So I have my nice new Kryoflux, and a brand new Sony MPF920 and running W7 Ultimate.

I have power to the disk drive, and have tried the disk drive either side of the twist on the cable.

I installed drivers as per the manual, and under USB Controllers in the Device manager, I can see KryoFlux Disk System

DTC -c2 brings up 'maxtrack=0'

In the GUI, when I click on Drive, then Calibrate, the lights on the Kryflux go from just the steady read power light, to the yellow and green pulsing, and the drive shunts around, but comes back with the error 'Could Not Communicate with Floppy Drive'

If I try to image a disk, it comes back with Track 0, Command Rejected, Red Failed.

If I don't have a disk in the drive, it returns with the error 'The streaming device reported missing index - no disk in drive'

I suspect I am doing something simple wrong.

Can someone confirm which plug on the ribbon cable the drive should be. I have the motherboard plug in the Kryoflux, then Drive 1 below nearest the motherboard plug, then Drive 0 after the twist. I currently have it plugged into Drive 0, but it doesn't change it's behavior in either.

I would be grateful for suggestions.

Thanks

Re: Problems (probably me)

Posted: Sun Feb 03, 2019 10:17 pm
by ZrX
With a single drive it really shouldn't matter which connector it's plugged into.

Everything also seems to be correct. If the drive is repeatedly stepping in and out before maxtrack value is displayed then it should come up with a valid value.

But if it just knocks the head shortly before maxtrack=0 then something is wrong.

Re: Problems (probably me)

Posted: Mon Feb 04, 2019 12:50 pm
by MarkYoungIW
OK, I tried also swapping the jumpers to allow 2 drives and tried the drive as drive 1 in the GUI as well, and that has the same effect.

Basically, the drive makes a couple of little clicks, then it returns the error. After it has returned the error, the drive makes an errr.......waits a while, makes another errr.........then halts.

Re: Problems (probably me)

Posted: Mon Feb 04, 2019 1:47 pm
by MarkYoungIW
How it looks so far:-

Windows 7 Ultimate

Drive in use.
https://drive.google.com/file/d/1o8VDmS ... sp=sharing

Calibration from Command Line.
https://drive.google.com/file/d/1sjI-rN ... sp=sharing

Also Command Line
https://drive.google.com/open?id=1wQEtY ... sp=sharing

Calibrate from GUI
https://drive.google.com/open?id=1LAP30 ... sp=sharing

Attempt to image a disk from GUI
https://drive.google.com/open?id=1ChbK3 ... sp=sharing

Attempt to image a disk from GUI without disk in drive.
https://drive.google.com/open?id=1ym4iP ... sp=sharing

Re: Problems (probably me)

Posted: Mon Feb 04, 2019 2:08 pm
by MarkYoungIW
Videos.

Calibrate from GUI without disk in (barely audiable)
https://drive.google.com/file/d/10A9aFV ... sp=sharing

Calibrate from GUI with disk in (slightly more audible)
https://drive.google.com/file/d/1-4YQj3 ... sp=sharing

Re: Problems (probably me)

Posted: Mon Feb 04, 2019 2:13 pm
by ZrX
Sounds like there's something wrong with either the drives stepper motor or the track 0 sensor.

Try to get access to another drive and possibly another flat cable to test where the error might be. Tho the cable is probably the one that came with your KF.

Re: Problems (probably me)

Posted: Mon Feb 04, 2019 5:57 pm
by MarkYoungIW
Sure enough, a dodgy drive.

Put in an old Citizen out of my archimedes, and worked first time.

Sorry about that. :-)

Re: Problems (probably me)

Posted: Mon Feb 11, 2019 1:41 pm
by mr.vince
Please keep in mind to upload images to the forums as we don't know for how long you will keep external links alive, renderding this topic useless when removed.