Page 1 of 1

Is my Kryoflux dead?

Posted: Sun Nov 11, 2018 9:02 pm
by Dozer

I've been using the Kryoflux board for 7 years now, and it has served me well. I have dumped a few thousand floppies over the last few weeks, and everything has been just perfect.

However, when I booted my "dumping-computer" today, (running linux, ubuntu 16.10 LTS), I just got "the drive doesn't support the reset command" from DTC.

Connecting it to a Windows-computer does not give me the "Bossa" port, but instead "Citrix Virtual Display Adapter". The 3.00 driver does not want to install. Forcing it in gives me just the "This device doesn't work properly".

Any tips? The board is, amazingly enough, exactly 7 years, so I guess I can get a new one if this one is indeed broken :)

Re: Is my Kryoflux dead?

Posted: Wed Nov 14, 2018 10:54 pm
by Dozer
So, an update since it's hard to get new boards :)

I got a tip from a friend. "Remove all cables, poweroff the board, set the "test" jumper, power on for 10 seconds, poweroff, remove the "test" jumper, and try again. This should reset the board incase the firmware is in some way corrupted"

So I did that. The rest is after I did so.

Linux (Ubuntu 16.04.5)

Plugging in the board:
[ 408.038043] usb 1-1.4: new full-speed USB device number 9 using ehci-pci
[ 408.130881] usb 1-1.4: New USB device found, idVendor=03eb, idProduct=6124
[ 408.130887] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 408.131383] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device

running DTC, the drive lights up, but no apparent access (as in, no sound)

root@fun-dump-01:~/kryoflux_2.6_linux/dtc# ./dtc -c2
Device control command failed
root@fun-dump-01:~/kryoflux_2.6_linux/dtc# ./dtc -c2
Device does not support Reset command

dmesg now updates with new info:
[ 457.760546] usb 1-1.4: USB disconnect, device number 9
[ 457.960045] usb 1-1.4: new full-speed USB device number 10 using ehci-pci
[ 458.054912] usb 1-1.4: New USB device found, idVendor=03eb, idProduct=6124
[ 458.054917] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 458.054920] usb 1-1.4: Product: KryoFlux DiskSystem
[ 458.054924] usb 1-1.4: Manufacturer:
[ 458.054926] usb 1-1.4: SerialNumber: 00000000

Windows (Windows 10. 1803, x64)

I plugged in, and got the "BOSSA" port, as expected (well, that's something atleast :)

Installed the latest driver from the DTC 3.00 package

In device manager, VID is 03EB and PID is 6124.

Reset the board, using the switch, and installed the driver again. (for some reason, this seems to be the standard the first time you install the driver.)

Now, when trying DTC, I get:

kryoflux_3.00_windows\dtc>DTC.exe -c2 -d0
Control command rejected by the device
CM: maxtrack=0

Same error when trying -d1 (I have two floppy drives connected, one 3.5" and one 5.25". Both worked perfectly a few days ago.)

The same thing with the floppydrives here. They light up, but no apparent access. I've tried several drives aswell.

And, while testing all this, powering down, switching over, the card got VERY hot... and in the end, let the magic smoke out. (as in, it seems like a few components fried).

I'll be standing in line for a new card, whenever they are available.

Re: Is my Kryoflux dead?

Posted: Thu Nov 15, 2018 12:18 am
by ZrX
The TEST jumper info was relayed from me.

So did that actually bring the board back for a moment?

And what was the reason for the board suddenly becoming fried? Shortcircuit?

Any detailed pics of what components got damaged?

Re: Is my Kryoflux dead?

Posted: Thu Nov 15, 2018 2:52 pm
by Dozer
Ah, cool :)

So, after I did the "TEST Jumper"-thing, the board did come up as "BOSSA" (which it did not in the original post)

This made me believe there was hope atleast.

When I said the board was "very hot", that was in the area where I've marked with a blue box.

The smoke, however, seemed to come from the area marked in yellow. There is a few capacitors around there, so I guess it could be one of those that just said goodbye. There is no visible damage to the board, as far as I could see yesterday. I do have a "USB Microscope" I can do a better inspection with later on today. If I find something weird, I will update this post.

EDIT mr.vince: External links to photos removed. Please store locally. The forum allows for image uploads.

And the reason why the board suddenly said "poof" ? I have no idea. I didn't have anything shorting it at the moment. It was upon powering the pc back up though, so I honestly have to say that I can't be 100% sure. As soon as I saw the white smoke, I powered down and called it the day soon after :)

Re: Is my Kryoflux dead?

Posted: Thu Nov 15, 2018 8:17 pm
by Dozer
So, I went over the board with a (very cheap) usb microscope, and couldn't find anything "out of the ordinary". No discolorations, no bulges on components and nothing that you wouldn't expect to find.

I'll just get in line for a new one. I'm really happy with the board, and from the looks of it, I did something / forgot something while in the midst of everything, and blew mine up. Lesson learned :)

Re: Is my Kryoflux dead?

Posted: Thu Nov 15, 2018 9:13 pm
by ZrX
The yellow area holds the voltage regulators. Blue area just a bit of protection for the input voltage. It really shouldn't get hot over USB.

Usually the PC would cut off the USB-port before such extreme voltages could be drawn by the board that would get the two regulators smoking. And those two also have a safety feature that cuts them off in case of excess current draw.