DTC -c2 > Device Not Found

All questions about how to use KryoFlux go here.
Posts: 618
Joined: Tue Dec 06, 2011 9:09 pm

Re: DTC -c2 > Device Not Found

Post by ZrX »

The control command rejected along with maxtrack 0 without a drive/power is just that. The hardware works but couldn't get a response from a drive since it didn't exist or wasn't powered up.

Posts: 26
Joined: Fri Jul 21, 2017 9:13 pm

Re: DTC -c2 > Device Not Found

Post by airnocker »

Here is an update to this issue that I discovered today. As I now infrequently create new disk images using Kryoflux, the last time I did was this past February, I ran into the same problem of having the wrong drivers load when plugging my kryoflux into the USB port. Disconnecting from the Internet and removing the Bossa drivers didn't work because this time no Bossa drivers where being installed, just a new COM5 Port driver for USB and nothing Kryoflux in the USB Device Manager section. It mattered not one whit that I was disconnected from the Internet, no Kryoflux driver would load, even after cold boots with not Internet connection. It was either a COM5 Port driver that loaded or the Bossa driver, period.

Now, I'm on Windows 10 Pro build 1902 and using the kryoflux_3.00_windows drivers.

On a whim, I path'd to the Kyroflux 3.00 Drivers folder and saw the INF file. I right clicked on it and selected "Install". It did AND BAM! the Kryoflux driver loaded and appeared in the USB section in Device Manager with no additional driver in the Ports section of Device Manager.

Then, everything worked as it did before.

Now, a word on that. Since being on Windows 10 Pro, build 1809 and the 3.00 Kryoflux driver version whenever I would do the initial "dtc -c2" for the first time I would get the following response:

Control command rejected by device
CM: maxtrack=0

This was consistent no matter how many times I tried initializing the kryoflux board. I found that by ignoring the command rejected feedback, powering up the Panasonic floppy drive that had worked so beautifully for hundreds of Apple II DOS3.3 disk images anyway and issuing the 2nd "dtc -c2" command I would get the following response:

CM: maxtrack=83

And everything worked properly when creating new disk images.

I hope this provides some help and insight for others.
Everything depends on everything else

User avatar
Posts: 2135
Joined: Tue Oct 05, 2010 5:48 pm

Re: DTC -c2 > Device Not Found

Post by mr.vince »

When you get the control command rejected... open the device manager. Check for KF, if it's not there, my bet is you'll find a Bossa device under COM. Right click, properties, go to where you can see the driver and version, chose to replace it - manually - and go to the drivers folder of the KF installation archive (you'll need to unpack it somewhere of course) and select it. This should do the trick.

EDIT: Did not see page 2. ;)

Post Reply