Page 1 of 1

What am I doing wrong ?

Posted: Sun Aug 19, 2018 7:37 pm
by Vipersan
Shortly after I completed my dual drive 3.5 & 5.25 inch kryo unit ..I had an MS relapse so not been well enough to experiment with it.
I'm now feeling a bit better and wanting to press on ..
I successfully read some PC dos game disks ..but these were like new ..
I figured it time to try and get to grips with HD 5.25" floppies ..
So I formatted one from DOS on a win98se PC ..and copied accross the system files ..
Format A: /s
and popped an executable on it for good measure ..
I checked I could see the floppy contents both in DOS and win98 ..then popped that floppy in my Kryo drive..
Selected MFM
80 tracks
left defaults on everything else except RPM ..changed from 300 to 360
set output to img ..and pressed start.
Nothing but grey both sides ..and no data in the img file created.

The floppy is a brand new /Old disk from a sealed box (DM brand DS/HD)
I am still using the gui as I have yet to learn how to use dtc.exe
easier to 'view' activity for a novice such as myself.
Obviously something I'm doing or _not_ doing ..as I can still read my Leasure suit larry 5.25 inch floppies ..so the kryo and drive are working.
once I solve this and understand the process ..I will make permanent 1.2mb and 360 profiles.
rgds
VS

Re: What am I doing wrong ?

Posted: Sun Aug 19, 2018 7:54 pm
by SomeGuy
The disk you formatted was 1.2mb high density?

Did you set the density line appropriately? With 1.2mb 5.25" floppy drives, it is very important that you set the density line to match the density of the disks. 3.5" drives usually detect this themselves and 360k drives ignore it. To confuse the matter more, the Kryoflux menu refers to the TTL Logic level sent to the drive rather than what they represent. On normal IBM PC style 1.2mb floppy drives, density line high=low density and density line low=high density.

Re: What am I doing wrong ?

Posted: Sun Aug 19, 2018 8:18 pm
by Vipersan
Well to be honest I didn't specify anything other that Format A: /s from DOS ..
and the floppy is as I said DS/HD ...and the result is readable from DOS or win98 ..
So yes ..it is possible that what I wrote to the disk in the PC was garbage..
I didn't know about the 5.25" disks requiring more info ..but then wouldn't Kryo be able to read it anyway ..if I knew how to set up the profile pre read ?
rgds
and thanks for replying..

Re: What am I doing wrong ?

Posted: Sun Aug 19, 2018 8:38 pm
by SomeGuy
I meant setting the density in the Kryoflux GUI for reading. If it is set wrong, the Kryoflux might not detect anything readable.

Re: What am I doing wrong ?

Posted: Mon Aug 20, 2018 12:21 am
by Vipersan
Pardon my ignorance ..but how to you set the density in the dtc gui ..?
I see no option for TTL logic level or Hi Lo density ..
Possibly this is manually entered in the 'Other Params' window ...below the tick options ?
but if so ..I have no idea of syntax..
rgds

Re: What am I doing wrong ?

Posted: Mon Aug 20, 2018 9:30 am
by mr.vince
Check the drop down menus. It's in the menu where you select the drive as well.

Re: What am I doing wrong ?

Posted: Mon Aug 20, 2018 10:42 am
by Vipersan
Many thanks ..I found the density option in the drive select menu as you suggested ..but not on the parameter options screen.
Which to my thinking is odd ..as you cannot set it to automatically untick (low) = high when creating a new profile.
Nonetheless ..I appreciate your help ..and yes it reads the disk perfectly now..
cheers
VS