Shugart 851 error

All questions about how to use KryoFlux go here.
Post Reply
adamsabi
Posts: 19
Joined: Thu Feb 09, 2017 9:30 pm

Shugart 851 error

Post by adamsabi » Wed Jan 10, 2018 4:45 pm

I have successfully connected up a refurbished 8" floppy drive, a Shugart 851, to the KryoFlux but when I attempt to create the preservation stream files, I receive a message like this, which I've attached to this post.

Can't create stream file
The streaming device reported missing index - no disk in drive
Read operation failed

Has anyone else encountered this problem before? I'm wondering if there might be a malfunction with one of the drive sensors.

Any help is greatly appreciated

Best,
Abby
Attachments
8in_floppy_error.JPG

User avatar
IFW
Posts: 3075
Joined: Mon Nov 08, 2010 2:42 pm

Re: Shugart 851 error

Post by IFW » Wed Jan 10, 2018 5:44 pm

This can have various origins, but the net result is always that the index signal never gets asserted by the drive.
Some possible reasons:
- really no disk in drive
- the disk does not rotate properly (e.g. stuck in the jacket)
- index line is not connected/not working
- index sensor is not working
- the index signal is connected to a different pin than where it should be on a standard Shugart interface

adamsabi
Posts: 19
Joined: Thu Feb 09, 2017 9:30 pm

Re: Shugart 851 error

Post by adamsabi » Wed Jan 10, 2018 5:52 pm

There is definitely a disk in the drive, and it is rotating so I think I can rule out the first two reasons. How would I determine whether the cause is due to one of the last three (index line, sensor, or signal)?

This is my first go at working with an 8" floppy drive, and I feel like I'm so close to getting it to work. Thanks for your help!

User avatar
IFW
Posts: 3075
Joined: Mon Nov 08, 2010 2:42 pm

Re: Shugart 851 error

Post by IFW » Wed Jan 10, 2018 5:56 pm

If you can get an exact pinout for the drive, compare it with the pinout of the standard Shugart (PC) interface.
I am not sure whether your drive requires an adaptor to make it behave like a standard PC drive.
You can also check the signals getting asserted by a scope.

User avatar
IFW
Posts: 3075
Joined: Mon Nov 08, 2010 2:42 pm

Re: Shugart 851 error

Post by IFW » Wed Jan 10, 2018 5:57 pm

You could also try replacing the cable, just in case.

Post Reply