Red LED is on but nothing else happens

All questions about how to use KryoFlux go here.
Eboreus
Posts: 3
Joined: Fri Dec 22, 2017 11:12 pm

Red LED is on but nothing else happens

Post by Eboreus » Sat Dec 23, 2017 4:05 pm

Hello!

yesterday the ordered "KryoFlux Personal Edition" board arrived here and I wanted to get it up running and test it. I followed the QUICKSTART guide up to step 8. When I try to connect the board via USB cable, the red LED switches on but nothing else happens.

There seems to be no visual reaction besides the red LED shining all the time. There's no sound, no other LEDs and there seems to be no change in the hardware listing either, no „Bossa“ device and no „KryoFlux Disk System“. When I press the RESET button on the KryoFlux board, it seems to have no effect. The red LED stays on and doesn't get interrupted by the RESET button. I checked the KryoFlux board and I can't see anything wrong there. The TEST jumper is not closed.

Just to be sure, I tried the KryoFlux board with 4 different PCs, new hardware and old hardware, Windows 7 64Bit, Windows XP and Linux Mint. I also tried 2 different USB cables in addition to the one that came with the KryoFlux board. But I could not get a different result than what I got before: As long as the USB cable is connected, the red LED is on and nothing else happens.

Could there be something I'm missing here? Or could it be that the KryoFlux board is faulty?

Thanks a lot in advance for your help!

brightcaster
Posts: 143
Joined: Fri Nov 08, 2013 10:48 pm

Re: Red LED is on but nothing else happens

Post by brightcaster » Sat Dec 23, 2017 5:12 pm

There should be something like "atmel bootloader" or "at91sam" if you use the lsusb command on linux mint. As long as the firmware is not loaded the behavior you discribed is correct...

Sorry but I can only speak for linux, as I'm not that familiar with windows. Maybe there is also a command which shows all conected usb devices even if their drivers are missing?

David

Eboreus
Posts: 3
Joined: Fri Dec 22, 2017 11:12 pm

Re: Red LED is on but nothing else happens

Post by Eboreus » Sat Dec 23, 2017 6:49 pm

brightcaster wrote:
Sat Dec 23, 2017 5:12 pm
There should be something like "atmel bootloader" or "at91sam" if you use the lsusb command on linux mint. As long as the firmware is not loaded the behavior you discribed is correct...

Sorry but I can only speak for linux, as I'm not that familiar with windows. Maybe there is also a command which shows all conected usb devices even if their drivers are missing?

David
Hi David,

thanks for your reply!

I used "usbview" in Linux to check. Now I checked again with the following commands:
  • lsusb
  • usb-devices
  • cat /sys/bus/usb/devices/*/product
It seems like the KryoFlux doesn't show up. I don't know if there's another way to get more information about connected devices without drivers in Linux. My Linux Mint 18.2 has "libusb-1.0.20" and kernel "4.10.0-42" installed. Maybe something is still missing?!

User avatar
mr.vince
Posts: 2099
Joined: Tue Oct 05, 2010 5:48 pm

Re: Red LED is on but nothing else happens

Post by mr.vince » Fri Dec 29, 2017 10:27 am

Any news?

brightcaster
Posts: 143
Joined: Fri Nov 08, 2013 10:48 pm

Re: Red LED is on but nothing else happens

Post by brightcaster » Mon Jan 01, 2018 7:33 pm

Maybe its related with the USB powering covered in this thread:

viewtopic.php?f=3&t=761&start=10

But I guess You allready checked that...

David

Eboreus
Posts: 3
Joined: Fri Dec 22, 2017 11:12 pm

Re: Red LED is on but nothing else happens

Post by Eboreus » Sun Jan 14, 2018 12:17 pm

Sadly I couldn't get the first board running and so I finally got a replacement board. The second board worked right away without any trouble, where the first board didn't want to work. So I think the first board may have had some issues somehow. Now everything is running well and I'm happy with the KryoFlux.

Thanks for the help everybody! :)

User avatar
IFW
Posts: 3077
Joined: Mon Nov 08, 2010 2:42 pm

Re: Red LED is on but nothing else happens

Post by IFW » Mon Jan 15, 2018 10:33 pm

Glad to hear that - have fun :)

BlindGerMan
Posts: 9
Joined: Sun Jan 28, 2018 1:39 pm

Re: Red LED is on but nothing else happens

Post by BlindGerMan » Sun Jan 28, 2018 4:19 pm

Hi,

I bought a kyroflux around Christmas and yesterday I had finally the time to open and start using it...

But I have the same problem... The red light is on, but nothing happens. I tried is under Windows 7 and Windows 10 with 3 different computers. I cannot Install drivers etc.

looking for help!!

BlindGerMan
Posts: 9
Joined: Sun Jan 28, 2018 1:39 pm

Re: Red LED is on but nothing else happens

Post by BlindGerMan » Mon Jan 29, 2018 11:43 am

Any help for me out there???

User avatar
mr.vince
Posts: 2099
Joined: Tue Oct 05, 2010 5:48 pm

Re: Red LED is on but nothing else happens

Post by mr.vince » Mon Jan 29, 2018 12:36 pm

Patience, young Padawan. You might have noticed it's been Sunday yesterday. :)

Try a different USB cable please and check what happens under COM ports in device manager when you attach the board.

BTW: any open jumpers on the board?

Post Reply