Windows 7 - Kryoflux board not recognized

All questions about how to use KryoFlux go here.
timhutchinson
Posts: 6
Joined: Fri Mar 03, 2017 4:34 pm

Windows 7 - Kryoflux board not recognized

Post by timhutchinson » Mon Mar 06, 2017 6:32 pm

Hi,

It's been a couple years since I fired up my Kryoflux - at which point it was new. The device seems to be no longer recognized.
- on two separate newish Windows 7 machines, I am not prompted for driver information, and I can't find the device listed in Device Manager
- I tried it on the laptop I was using originally: I also can't find the device listed; and dtc -c2 gets an error message (device not found or the equivalent - I no longer have that machine in front of me)
- I tried two different USB cables and verified that both work (with a scanner)
- the LED light does come on.

I'm concerned that the board might be damaged. Is there anything I can try? Where should it be appearing in the Device Manager? Thanks for any assistance.

Tim Hutchinson
University of Saskatchewan

BarryB
Posts: 263
Joined: Thu Aug 02, 2012 8:15 pm

Re: Windows 7 - Kryoflux board not recognized

Post by BarryB » Mon Mar 06, 2017 11:31 pm

Look under COM Ports as it may be recognised as Bossa, or some name similar, then manually update the driver with the proper Kryoflux driver to see if that recognises it.

timhutchinson
Posts: 6
Joined: Fri Mar 03, 2017 4:34 pm

Re: Windows 7 - Kryoflux board not recognized

Post by timhutchinson » Wed Mar 08, 2017 6:57 pm

Thanks for the suggestion. Unfortunately that doesn't seem to be the case. I'm not even getting a notification that a new device is being installed.

BarryB
Posts: 263
Joined: Thu Aug 02, 2012 8:15 pm

Re: Windows 7 - Kryoflux board not recognized

Post by BarryB » Wed Mar 08, 2017 9:11 pm

Is there power getting to the KF board, any LEDs lit? How are you setting it up?

timhutchinson
Posts: 6
Joined: Fri Mar 03, 2017 4:34 pm

Re: Windows 7 - Kryoflux board not recognized

Post by timhutchinson » Wed Mar 08, 2017 9:13 pm

One LED lights up - power is via USB (computer, not hub).

User avatar
mr.vince
Posts: 1870
Joined: Tue Oct 05, 2010 5:48 pm

Re: Windows 7 - Kryoflux board not recognized

Post by mr.vince » Wed Mar 08, 2017 9:16 pm

Ok, one light... that seems like it's the red one. If you don't get any notification, I am pretty sure it's already there. Please check device manager under "com" ports. I'd assume you have a Bossa device.

timhutchinson
Posts: 6
Joined: Fri Mar 03, 2017 4:34 pm

Re: Windows 7 - Kryoflux board not recognized

Post by timhutchinson » Wed Mar 08, 2017 9:38 pm

I'm told it's red/amber: to the left of the reset button (which I also just tried).

Under COM ports I'm only seeing Intel Active Management Technology - SOL (COM3)

User avatar
mr.vince
Posts: 1870
Joined: Tue Oct 05, 2010 5:48 pm

Re: Windows 7 - Kryoflux board not recognized

Post by mr.vince » Thu Mar 09, 2017 6:58 am

I'd recommend switching the USB cable and / or using a different computer, just to find out what the culprit is.

timhutchinson
Posts: 6
Joined: Fri Mar 03, 2017 4:34 pm

Re: Windows 7 - Kryoflux board not recognized

Post by timhutchinson » Sat Mar 11, 2017 12:34 am

I have tried three computers and 2 USB cables. As I mentioned at the outset, I had it working a couple years ago, and I tried it on the same computer. Is it worth trying an external power supply?

User avatar
mr.vince
Posts: 1870
Joined: Tue Oct 05, 2010 5:48 pm

Re: Windows 7 - Kryoflux board not recognized

Post by mr.vince » Sat Mar 11, 2017 5:10 pm

What for? The board does not need external power and if the red led is on, it's powered.

If you can't get it to work please feel free to send it in for inspection.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest