Mac: USB endpoint not found

All questions about how to use KryoFlux go here.
sky76
Posts: 39
Joined: Sat Jun 27, 2015 1:27 pm

Re: Mac: USB endpoint not found

Post by sky76 »

On the Download page it says it is compatible with macOS 10.11 when in fact on 10.12 it is also working.
Are there plans to support macOS Mojave or Catalina in the future?
A1200 + Indivision AGA + ACA1233 & Blizzard 1230IV+SCSI + easynet
A600 + Indivision ECS + ACA620 + A604n // CD32 + SX32 MK2 + Indivision AGA
A500 + ACA500 + 5 spare A500's (one with the C= key, Serial No 3358)
whitehusky
Posts: 9
Joined: Sat Aug 01, 2020 3:31 am

Re: Mac: USB endpoint not found

Post by whitehusky »

Just got my KryoFlux and also am disappointed to see it doesn't run in 10.15. There was a comment that judging by the downloads, 95% of users are on Windows - well, yeah, if the Mac app doesn't work, of course all the downloads will be Windows LOL. I also was forced to download and use the Windows version once I found this thread and confirmed that the Mac version of the app is broken.
brightcaster
Posts: 319
Joined: Fri Nov 08, 2013 10:48 pm

Re: Mac: USB endpoint not found

Post by brightcaster »

It's not the mac version of the kryoflux software which is broken but the USB stack of the mac OS!!!

David
robbo007
Posts: 89
Joined: Wed May 23, 2012 2:56 pm
Location: Spain

Re: Mac: USB endpoint not found

Post by robbo007 »

@whitehusky. Just use boot camp windows 10.

I wouldn’t expect a fix for this. It’s a shame. I hate booting into windows to dump floppies. A real pain in the arse.

What I dont understand if the usb stack is broken in Mojave and above why don’t I have any other problems with all my USB devices? Everything works fine I plug in except the Kryoflux. 🤷🏼‍♂️
brightcaster
Posts: 319
Joined: Fri Nov 08, 2013 10:48 pm

Re: Mac: USB endpoint not found

Post by brightcaster »

You may just type "mojave usb problems" into google search to see how many other usb devices got problems...

One of the longer threads about the issue is found here:

https://www.tonymacx86.com/threads/guid ... xt.211311/

David
sky76
Posts: 39
Joined: Sat Jun 27, 2015 1:27 pm

Re: Mac: USB endpoint not found

Post by sky76 »

Well, you can type "*INSERT_ANY_OS_HERE* usb problems" into google search and get a lot of results...
A1200 + Indivision AGA + ACA1233 & Blizzard 1230IV+SCSI + easynet
A600 + Indivision ECS + ACA620 + A604n // CD32 + SX32 MK2 + Indivision AGA
A500 + ACA500 + 5 spare A500's (one with the C= key, Serial No 3358)
whitehusky
Posts: 9
Joined: Sat Aug 01, 2020 3:31 am

Re: Mac: USB endpoint not found

Post by whitehusky »

Well, to be fair, the tonymacx86 forums are for Hackintosh users (people trying to run macOS on normal PC's), and yes, they run into all kinds of issues getting macOS to run on non-Apple hardware, but that's not related to the issue here.
Post Reply