Weird Reading Several C64 Disks In A Row

All questions regarding the dumping of media go here.
Post Reply
Posts: 6
Joined: Wed Apr 06, 2011 7:21 pm

Weird Reading Several C64 Disks In A Row

Post by skideric »

Had thought one of my FD-55GFR drives had bit the dust
First couple c64 Test Disks read did fine,then it seemed the drive head stopped reading tracks of the next disks (heads were cleaned).Then i tried reading an Apple II Disk & all was fine! ? So tried the c64 disk after that & it read fine...?? Seems by switching the reading profile & dumping An Apple disk it worked as though software had been reset?
Any & all comments on this issue welcome.
Thanks in advance....
Posts: 121
Joined: Mon Nov 21, 2011 5:21 pm

Re: Weird Reading Several C64 Disks In A Row

Post by rcade »

This happens to me also, but slightly differently.

After imaging a number of PC disks (not sure the type matters) it will start saying that all data on side 0 is unformatted. I think the head is dirty, it is not, I clean it anyway. However, reading a disk of another type (C64 for example) shows it can read that head OK. I go back to the same PC disk, and it works again.
Pete Rittwage
C64 Preservation Project
Posts: 758
Joined: Fri Jun 03, 2011 8:29 pm
Location: Jyväskylä, Finland

Re: Weird Reading Several C64 Disks In A Row

Post by Rakki »

Sometimes its nearly impossible to see whether the head is dirty or not so it may need careful cleaning. Also the board reset may help in some rare problem cases (the gradual deterioration of the media, too much noise in the stream). You can check the data quality with graphs (latest 3.x software versions).

Please check the density line setting (dd0 / dd1):

Graphical representation of the density line
Post Reply